Dicas de Tecnologia

Saiba como filtrar e somar itens específicos em uma tabela no Excel

Rodrigo Loureiro

Do UOL, em São Paulo

A leitora Daiane entrou em contato com o UOL Tecnologia perguntando como poderia fazer a soma de dados isolados de uma tabela automaticamente. De acordo com a internauta, a intenção dela era somar valores de vendas de produtos iguais, mas vendidos para clientes diferentes e em datas diversas.

Para fazer isso de forma automática, é preciso utilizar a função "Subtotal" do Excel aliada do recurso "Filtrar". Com elas será possível realizar as contas selecionando os tipos de dados de forma prática e rápida. Veja como:

Filtre e some itens específicos em uma tabela
  • Reprodução
    1.
    A primeira coisa a fazer é criar uma tabela e preenche-la de acordo com os dados que possui. No exemplo, o UOL Tecnologia utilizou uma planilha de vendas de uma lanchonete fictícia Foto: Reprodução
  • Reprodução
    2.
    Depois de pronta, crie mais dois campos e intitule-os de Subtotal e Total Geral para facilitar a identificação futura Foto: Reprodução
  • Reprodução
    3.
    Agora selecione os itens da tabela, inclusive os campos que os caracterizam. No exemplo, esses campos são: Data, Produto e Preço Foto: Reprodução
  • Reprodução
    4.
    Com os dados selecionados, clique na guia "Dados" e escolha opção "Filtrar" Foto: Reprodução
  • Reprodução
    5.
    Se fizer corretamente, os campos descritivos irão contar com um pequeno botão que será usado para fazer a filtragem das informações Foto: Reprodução
  • Reprodução
    6.
    Volte às células que criou no Passo 2 deste tutorial e ao lado de Subtotal utilize a seguinte fórmula: =SUBTOTAL(9;célula com o primeiro preço:célula com o último preço). No exemplo, ficou assim: =SUBTOTAL(9;C4:C16) Foto: Reprodução
  • Reprodução
    7.
    Já ao lado da célula Total Geral insira a fórmula: =SOMA(célula com o primeiro preço:célula com o último preço).Como no exemplo: =SOMA(C4:C16) Foto: Reprodução
  • Reprodução
    8.
    Para classificar os valores obtidos pelas duas fórmulas como números monetários selecione-os e, na guia "Início", clique no campo de seleção que provavelmente vai estar com a inscrição "Geral" escolha a opção "Moeda" Foto: Reprodução
  • Reprodução
    9.
    Com a tabela pronta, selecione os dados que deseja filtrar clicando em algum dos botões inseridos campos descritos (no exemplo, Data, Produto e Preço). No caso, o exemplo deseja obter os resultados das vendas obtidas com Lanches e Refrigerantes Foto: Reprodução
  • Reprodução
    10.
    Observe que ao fazer o isso, o subtotal automaticamente é alterado, mas o total geral permanece igual, pois está configurado para calcular todos os campos inseridos Foto: Reprodução
  • Reprodução
    11.
    Se quiser filtrar os dados pela Data também é possível, basta repetir o processo Foto: Reprodução
  • Reprodução
    12.
    Pronto, desta forma você obtém resultados apenas dos campos que deseja somar. Aqui (http://uol.com/bkfZ9B), você pode baixar a tabela pronta. Foto: Reprodução

Receba notícias pelo Facebook Messenger

Quer receber as principais notícias do dia de graça pelo Facebook Messenger? Clique aqui e siga as instruções.

Veja também

UOL Cursos Online

Todos os cursos